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1. Introduction
Welcome to WinTPS – the gateway between TPS instruments and a personal computer. This
software package handles the communication protocols for all TPS instruments fitted with an
RS232 port. It is designed to quickly and easily download your vital data and even manage some of
the instrument's functions.

Please take the time to read this manual carefully, so that you can obtain the maximum benefit from
the software's capabilities.

Please note that all section references listed in this manual are hyper-linked. Simply click on a
section number to jump directly to that section.

1.1 Compatibility

WinTPS has been tested for compatibility with Microsoft Windows 95, 98, ME, 2000 and XP.

Pentium 100 MHz or higher with at least 16MB RAM recommended. The software will run on
slower machines, but performance may be decreased.

WinTPS uses less than 1MB of hard disk space.

1.2 What's on the WinTPS CD-ROM

The WinTPS CD-ROM contains the following…

Description Folder

WinTPS Communication Software setup files \WinTPS

WinTPS Manual \WinTPS Manual

Complete TPS Web Site, current at time of producing the
CD-ROM

\TPS

Communication Software for MS-DOS for…

90 Series .......................................................................................

900 Series .....................................................................................

WP Series .....................................................................................

\DOS Versions\90 Series

\DOS Versions\900 Series

\DOS Versions\WP Series

Microsoft Word Viewer 97, to view manuals which are in
Microsoft Word 97 format

\Word Viewer

TPS Screen Saver \TPS Screen Saver
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2. Installation
1. Insert the WinTPS CD-ROM into your CD-ROM drive.

2. The CD-ROM will automatically start and proceed to the WinTPS splash screen for most
machines…

Select Install WinTPS to proceed to the software installation.

If your computer does not automatically start the WinTPS setup…

(a) Click , then .

(b) Type d:\wintps\setup, where "d:" is the letter of your CD-ROM drive.

(c) Click .

3. Follow the instructions on the screen to install WinTPS.
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3. Launching WinTPS

To launch WinTPS, click , then , then , or double-click the WinTPS
icon on your desktop.

WinTPS will run the setup Wizard the first time the program is launched. Follow the step-by-step
instructions on the screen to set up WinTPS to your requirements.

1. Select the COM port to which your TPS instrument will be connected, and the baud rate at
which the instrument is set. TPS recommends that you begin by using the highest baud rate
available for your instrument. If any communication problems occur, this can be set to a lower
value later.

2. Select Data Conversions.

Asterisks (which are an indication of failed calibration) can be converted to decimal points
when data is saved. This should be used with caution, as the data may not be accurate.

Convert mS/cm to uS/cm for any Conductivity data as it is downloaded to ensure consistent
data for later analysis. This is highly recommended, as database and spreadsheet software will
produce results which differ by a factor of 1000 when some readings are in mS/cm and others
are in uS/cm.

Convert ppK to ppM for any Salinity, TDS or Specific Ion data as it is downloaded to ensure
consistent data for later analysis. This is highly recommended, as database and spreadsheet
software will produce results which differ by a factor of 1000 when some readings are in ppK
and others are in ppM.

Refer to the screen shot over the page…
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3. WinTPS is now configured. Click  to start the program.
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4. WinTPS Screen
Below is an example of the WinTPS screen with the major elements labelled.
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5. Instrument Operations

5.1 Detecting the Instrument Model

Menu Toolbar Shortcut Key

File → Detect Meter No toolbar icon for this function No Shortcut Key for this function

Not all of the functions detailed in this section are available with every TPS instrument. WinTPS
therefore automatically detects the model of the instrument whenever the programmed is started. A
message such as "Searching for meter on COM2 at 19200 baud…" is displayed in the status
bar while WinTPS searches for the instrument. The program will continue to search until a meter is
found, without timing out, allowing you to use the software "offline".

If communications fail at any stage for an unexpected reason (eg. meter is switched off), the
functions on the toolbar will be disabled until a meter is once again detected.

Select the Detect Meter function to manually start the instrument detection process.

5.2 “Listen” Mode

Menu Toolbar Shortcut Key

Display → Listen No Shortcut Key for this function

This function makes the computer wait for data to be sent from the instrument. Any data sent by
the instrument using the relevant “Print” function from within its menus will be sent to the WinTPS
Data Window. This function is ideal for users who wish to ensure readings are totally stable before
saving the data to the computer.

After selecting the Listen mode, use the instrument to send data to the computer. Refer to the
instrument’s handbook for details on what “Print” or “Send” functions are available.

Click  to stop the Listen mode.

Please see section 6.2 for details on saving the data before using any further WinTPS functions.
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5.3 Displaying Current Data from Instrument

Menu Toolbar Shortcut Key

Display → Current Ctrl + R

This function displays the data currently on the instrument's display. This function is ideal for using
your computer as a datalogger, as it provides an almost limitless storage capacity.

After selecting the Current Data function, enter the desired log interval in seconds, then click

. The allowable range is 1 to 3600 seconds. Please note that some instruments do not
allow a logging interval of less than 3 seconds.

The data will now begin to scroll into the WinTPS data window. The status bar displays a count
down in seconds to when the next reading is due.

Click  to stop the Current Data function.

Please see section 6.2 for details on saving the data before using any further WinTPS functions.

5.4 Downloading Logged Data from Instrument

Menu Toolbar Shortcut Key

Display → Log Ctrl + L

This function downloads all readings currently stored in the instrument's memory.

A progress indicator is displayed in the status bar during the download process.

Click  to quit before the Logged Data download is finished.

Please see section 6.2 for details on saving the data before using any further WinTPS functions.
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5.5 Erasing the Instrument's Log

Menu Toolbar Shortcut Key

File → Erase Log Ctrl + E

This function erases all readings currently stored in the instrument's memory.

Ensure that any valuable data in the instrument's memory is saved before proceeding.

WinTPS provides one last warning before erasing the data…

WinTPS confirms that the logged data has been erased.

5.6 Downloading GLP Data from Instrument

Menu Toolbar Shortcut Key

Display → GLP Ctrl + G

This function downloads Good Laboratory Practices data currently stored in the instrument's
memory.

Please see section 6.2 for details on saving the data before using any further WinTPS functions.
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5.7 Displaying the Instrument's Battery Volts (90 Series only)

This function is only available for TPS 90 Series instruments.

Menu Toolbar Shortcut Key

Display → Voltage No toolbar icon for this function Ctrl + V

This function downloads the current voltage level of the battery in a 90 Series instrument. This data
can be used to remotely check the condition of the battery.

Please see section 6.2 for details on saving the data before using any further WinTPS functions.

5.8 Enabling and Disabling Automatic Datalogging (90 Series only)

This function is only available for TPS 90 Series instruments.

Menu Toolbar Shortcut Key

No Menu item for this function

  and  

No Shortcut Key for this function

This function remotely enables and disables the automatic datalogging facility of 90 Series
instruments. Automatic Datalogging was optional for any 90 Series units before Version 6.

The messages "Logging enabled." and "Logging disabled." appear in the status bar to indicate
that the commands have been issued to the instrument.

NOTE : To actually start Automatic Datalogging, the 90 Series unit must be switched OFF (see
section 5.10).

Please see the instrument's own handbook for more details on Automatic Datalogging.

5.9 Starting and Stopping the Dissolved Oxygen Stirrer (90 Series only)

This function is only available for TPS 90 Series instruments.

Menu Toolbar Shortcut Key

No Menu item for this function

  and  

No Shortcut Key for this function

This function remotely starts and stops the optional Dissolved Oxygen stirrer connected to a 90
Series instrument. Ensure that your 90 Series unit has the stirrer output activated and a stirrer
connected to the Dissolved Oxygen sensor socket.

The message "Stirrer started." appears in the status bar and the Dissolved Oxygen stirrer operates
continuously.

Click  to stop the stirrer. The message "Stirrer stopped." appears in the status bar.

Please see the instrument's own handbook for more details on the Dissolved Oxygen stirrer
operation.
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5.10 Switching the Instrument ON and OFF (90 Series only)

This function is only available for TPS 90 Series instruments.

Menu Toolbar Shortcut Key

No Menu item for this function

  and  

No Shortcut Key for this function

This function remotely switches a 90 Series instrument ON and OFF.

The status bar indicates the progress of these commands as they are issued.

NOTE : The 90 Off function must be used after enabling Automatic Datalogging to actually start
logging (see section 5.8).

Please see the instrument's own handbook for more details on Automatic Datalogging.

5.11 Downloading Max/Min Temperature Data (WP-87 & WP-87T only)

This function is only available for TPS WP-87 and WP-87T digital thermometers.

Menu Toolbar Shortcut Key

No Menu item for this function No Shortcut Key for this function

This function downloads the current Maximum and Minimum Temperature data for all active
channels from a TPS WP-87 or WP-87T instrument.

Please see section 6.2 for details on saving the data before using any further WinTPS functions.
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6. File Operations

6.1 Opening Files

Menu Toolbar Shortcut Key

File → Open Ctrl + O

Opens data files previously saved by WinTPS. The default folder is C:\My Documents\WinTPS.
Although the function allows all types of files to be opened, only those saved by WinTPS will
display correctly in the data window.

6.2 Saving Data

Menu Toolbar Shortcut Key

File → Save Ctrl + S

Saves data currently in the data window. This function is only available when there is data in the
data window.

Data can be saved in text format with a ".txt" extension or as a comma delimited format with a
".csv" extension.

The text format file is saved exactly it is displayed in the data window.

The comma delimited format file is saved with a comma between each data field and with the units
removed.

Both formats can be imported into popular database, spreadsheet and word processing applications.
Section 13 provides details on importing text format files into Microsoft Excel.

6.3 Printing Data

Menu Toolbar Shortcut Key

File → Print Ctrl + P

Prints the data currently being displayed in the data window. This function is only available when
there is data in the data window.

NOTE : Print Setup is available from the File menu to enable you to set the printer parameters
without actually printing the data.
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6.4 Data Conversions

Menu Toolbar Shortcut Key

Setup → Data Format No toolbar icon for this function No Shortcut Key for this function

Asterisks (which are an indication of failed calibration) can be converted to decimal points when
data is saved. This should be used with caution, as the data may not be accurate.

Convert mS/cm to uS/cm for any Conductivity data as it is downloaded to ensure consistent data for
later analysis. This is highly recommended, as database and spreadsheet software will produce
results which differ by a factor of 1000 when some readings are in mS/cm and others are in uS/cm.

Convert ppK to ppM for any Salinity, TDS or Specific Ion data as it is downloaded to ensure
consistent data for later analysis. This is highly recommended, as database and spreadsheet software
will produce results which differ by a factor of 1000 when some readings are in ppK and others are
in ppM.

Click  to save the Data Conversions setup. The setting is saved so this does not need to
be re-set each time WinTPS is started.
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6.5 Editing Functions

The following functions are available for the data being displayed in the data window.

Menu Shortcut Key Action

Edit → Copy Ctrl + C Copies selected data to the Clipboard.

Edit → Select All Ctrl + A Selects all data in the data window, including
any data that has scrolled off the screen.

Edit → Clear Shift + Delete Clears the data window.

Edit → Undo Clear Ctrl + Z Restores data that was cleared from the data
window.

Edit → Find Ctrl + F Finds text in the data window.

No Menu item for this function Home Cursor moves to the beginning of the line.

No Menu item for this function End Cursor moves to the end of the line.

No Menu item for this function Shift + Home Selects all data between current cursor
position and the beginning of the line.

No Menu item for this function Shift + End Selects all data between current cursor
position and the end of the line.

No Menu item for this function Ctrl + Home Cursor moves to the beginning of the data
window.

No Menu item for this function Ctrl + End Cursor moves to the end of the data window.

No Menu item for this function Shift + Ctrl + Home Selects all data between current cursor
position and the beginning of the data window.

No Menu item for this function Shift + Ctrl + End Selects all data between current cursor
position and the end of the data window.

No Menu item for this function Page Up Cursor moves 39 lines down the data window.

No Menu item for this function Page Down Cursor moves 39 lines up the data window.

NOTE : All items in the Edit menu are also available when right-clicking the mouse in the data
window.

Data can also be selected by clicking and holding the left mouse button in the data window, then
dragging the cursor over the text to be selected.
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7. Help Files

Menu Toolbar Shortcut Key

Help → Help (General) Ctrl + H

Help → Help (90 Series) No toolbar icon for this function No Shortcut key for this function

Displays on-screen help for WinTPS functions. Click on the functions to display details for those
functions.

Click  within the Help system to print the help topics.

Click Exit help to exit the Help system.

8. About TPS

Menu Toolbar Shortcut Key

Help → About TPS No toolbar icon for this function No Shortcut key for this function

Displays contact details for TPS, and includes links to generate an email to TPS using your default
email program, the TPS Web Site and the TPS Catalogue on the WinTPS CD-ROM.

9. Exiting WinTPS

Menu Toolbar Shortcut Key

File → Exit No toolbar icon for this function Ctrl + X

Exits the WinTPS program.
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10. Browsing the TPS Catalogue

Menu Toolbar Shortcut Key

Help → Browse Catalogue No toolbar icon for this function No Shortcut Key for this function

Automatically opens the index page of the TPS Web Site on the WinTPS CD-ROM. If the file is
not found, WinTPS offers you to enter the drive letter containing the WinTPS CD-ROM.

Select the correct drive letter and click .

The Web Site will appear in your default Web Browser…

Click on  to begin navigating through the TPS Web Site on your computer.
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11. Running the Setup Wizard

Menu Toolbar Shortcut Key

Setup → Wizard No toolbar icon for this function No Shortcut Key for this function

Although the Setup Wizard runs automatically the first time WinTPS is launched, it can also be run
whenever any setup parameter needs to be changed.

Please refer to section 3 for step-by-step details on running through the Setup Wizard.

12. Installing the TPS Screen Saver
To install the TPS Screen Saver…

1. Insert the WinTPS CD-ROM into your CD-ROM drive.

Select Exit when the WinTPS splash screen is displayed.

(Not required if the WinTPS CD does not start automatically.)

2. Click , then .

3. Type d:\TPS Screen Saver\setup, where "d:" is the letter of your CD-ROM drive.

4. Click .

5. Follow the instructions on the screen to install the TPS Screen Saver.
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13. Importing Text into Microsoft Excel

The following procedure details the method for importing a text data file into Microsoft Excel.

1. Start Microsoft Excel and select File → Open

2. In the “Files of type:” pull-down box, choose “Text Files (*prn; *.txt; *.csv)”.

3. Navigate to the folder where your data file is stored and double-click it to start the Text Import
Wizard.

Note : The default data folder for the WinTPS software is “C:\My Documents\WinTPS”.

4. In step 1 of the Text Import Wizard select “Fixed width”, as per the sample screen below,
then press “Next >”.

Note that the data column headers in row appear only when the data is downloaded using the
WinTPS software.
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5. Step 2 of the Text Import Wizard allows you to select the points at which each data field will
break into a new column. The sample screens below show where TPS recommends the breaks
be inserted.

The date and time have been incorporated into a single column to ensure that the X-axis is
correctly formatted if the data is to be charted later.

Press “Next >” after all the column breaks have been inserted.

6. Simply press “Finish” at step 3 of the Text Import Wizard. TPS recommends that the data
format for each column be set once the data is in spreadsheet format.

For help on formatting the data columns, charting, graphing or other operations please consult
the Microsoft Excel help file. Alternatively please contact TPS and we will try to provide
further assistance.


